BluetoothChatService

Android >
BluetoothChatService

public class BluetoothChatService

Description

Initialize, Connet/Disconnect and Tranmit data for Bluetooth service.

Methods

public
BluetoothChatService(Handler handler);
public
synchronized void connect(BluetoothDevice device);
public void write(byte[] buffer);
public synchronized int getState();
public synchronized void stop();

Requirements

Import | import com.PointMobile.PMSyncService.BluetoothChatService;
Library | PM3SDK.jar

Copyright 2014 Pointmobile Corporation


BluetoothChatService

Initialize the Bluetooth Service.

Syntax

 void BluetoothChatService(Context context, Handler handler);

Parameters

context
   MainActivity context.
handler
   MainActivity handler.

Return Value

None.

Requirements

Import | import com.PointMobile.PMSyncService.BluetoothChatService;
Library | PM3SDK.jar

See Also

connect

Example

 private BluetoothChatService mChatService = null;

 mChatService = new BluetoothChatService(mHandler);


connect

Connect to the Bluetooth scanner.

Syntax

 void connect(BluetoothDevice device);

Parameters

device
   the Bluetooth scanner information which has MAC address.

Return Value

None.

Requirements

Import | import com.PointMobile.PMSyncService.BluetoothChatService;
Library | PM3SDK.jar

See Also

BluetoothChatService

Example

 private BluetoothChatService mChatService = null;
 private BluetoothAdapter mBluetoothAdapter = null;

 mBluetoothAdapter = BluetoothAdapter.getDefaultAdapter();

 mChatService = new BluetoothChatService(mHandler);
 String address = "0019013FEEDC"; //GET MAC Adress,

 BluetoothDevice device = mBluetoothAdapter.getRemoteDevice(address);

 mChatService.connect(device);


write

Send data to the Buetooth scanner.

Syntax

 void write(byte[] buffer);

Parameters

buffer
   Data to be sent.

Return Value

None.

Requirements

Import | import com.PointMobile.PMSyncService.BluetoothChatService;
Library | PM3SDK.jar

See Also

Bluetooth Get State

Example

 if (mChatService.getState() == 3) {
    mChatService.write(buffer);
 }


getState

Get the Bluetooth connection state.

Syntax

 int getState();

Parameters

None.

Return Value

The connection states are defined as follows.
   0 : STATE_NONE
   1 : STATE_LISTEN
   2 : STATE_CONNECTING
   3 : STATE_CONNECTED

Requirements

Import | import com.PointMobile.PMSyncService.BluetoothChatService;
Library | PM3SDK.jar

See Also

write

Example

 if (mChatService.getState() == 3) {
    mChatService.write(buffer);


stop

Stop the Bluetooth connection.

Syntax

 void stop();

Parameters

None.

Return Value

None.

Requirements

Import | import com.PointMobile.PMSyncService.BluetoothChatService;
Library | PM3SDK.jar

See Also

None.

Example

 @Override
  public void onDestroy() {
    super.onDestroy();
    if (mChatService != null)
      mChatService.stop();


SendCommand

Android >
SendCommand

public class SendCommand

Description
Command Set to control the Bluetooth scanner through wirelss connection.

Methods
// SendCommand Class Initialize
void SendCommandInit(BluetoothChatService BTChatService, Handler handler);

// Scanner Options
Result ScanSetBeep(boolean BeepEnable);
Result ScanSetLED(boolean LEDEnable);
Result ScanSetTriggerTimeout(int TriggerTimeout);
Result ScanSetAutoScan(boolean AutoscanEnable);
Result ScanSetAutoScanTimeInterval(int Timeinterval);
Result ScanSetPowerSaveMode(int PowerSaveMode);
Result ScanSetPowerSaveTimeout(int PowerSaveTimeout);
Result ScanSetTerminator(int Terminator);
Result ScanSetTransmitBarcodeID(boolean BarcodeIDEnable);
Result ScanSetPrefixLabel(String Prefix);
Result ScanSetSuffixLabel(String Suffix);
Result ScanSetLiniearSecurityLevel(int SecurityLevel);
Result ScanSetInverse1D(int Inverse1D);
Result ScanLock(boolean ScanLock);
Result ScanSetRedundancyLevel(int RedundancyLevel);
Result ScanSetSecurityLevel(int SecurityLevel);
Result ScanSetPickListMode(boolean PickListModeEnable);
Result ScanSetScanAngle(int ScanAngle);
Result ScanSetAdaptiveScanning(boolean AdaptiveScanningEnable);

// Symbology
Result ScanEnableSymbologies(int SymEnable0);                   // N4313, SE965HP and SE655
Result SE4710EnableSymbologies(int SymEnable0, int SymEnable1); // SE4710
Result ScanSetSymbologyOptions(int symbologyID, byte[] DetailBuffer);

// Trigger
Result ScanSetTrigger();

// GPS Configuration
Result GPSSetPower(int PowerEnable);
Result GPSSetPowerMode(int PowerMode);
Result GPSReset();
Result GPSSetBypassData(boolean BypassEnable);

//
NFC Configuration
Result NFCSetPower(int PowerEnable);
Result
NFCEnableAutoDetect(boolean AutoDetect);
Result NFCEnableTagType(int
TagType);
byte[] NFCGetDetectInfo();
Result NFCMifareClassicSetKey(byte[]
SetKey);
Result NFCMifareClassicAuthenticateBlock(int AuthBlock);
Result NFCMifareClassicAuthenticateSector(int AuthSector);
byte[]
NFCMifareClassicReadBlock(int ReadBlock);
byte[]
NFCMifareClassicReadSector(int ReadSector);
byte[] NFCTypeADataExchange(int
APDU);
byte[] NFCTypeBDataExchange(int APDU);
Result
NFCReadComplete();

// System Settings
Result SysSetAutoErase(boolean AutoEraseEnable);
Result SysSetBeepVolume(int BeepVolume);
Result SysSetDateTime(String Datetime);
Result SysSetButtonLock(boolean ButtonLock);
Result SysFactoryReset();
Result SysSetScanSuccessVibration(int VibraotorSuccess);
Result SysSetScanFailVibration(int VibraotorFail);
Result SysResetMemory();
Result SysSetAlertCommand(int BeepType, int VibratorInterval, String FirtstLine, String SecondLine);
Result SysSetAlertMessageEx(int BeepType, int VibratorInterval, String FirtstLine, String SecondLine, String ThirdLine, String FourthLine);

// Utility
Result SysSetDeviceSettings(String Settings);
String SysGetDeviceSettings();
Result SysRequestAllScanData(boolean BeepSoundEnable);

// Device Information
String BTGetMACAddress();
String BTGetFWVersion();
String NFCGetFWVersion();
int SysGetNumberOfStoredBarcodes();
int SysGetFreeMemory();
int SysGetBatteryStatus();
String SysGetDeviceFWVersion();
String SysGetDeviceSerialNumber();
int SysGetScannerType();
String SysGetPartNumber();

Requirements

Import

import com.PointMobile.PMSyncService.Protocol;
import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;

Library PM3SDK.jar


SendCommandInit

Initialize SendCommand class.

Syntax

 void SendCommandInit(BluetoothChatService BTChatService, Handler handler);

Parameters

BTChatService
   Bluetooth connection information.
handler
   MainActivity handler.

Return Value

None.

Requirements

Import | import com.PointMobile.PMSyncService.SendCommand;
Library | PM3SDK.jar

See Also

BluetoothChatService

Example

 private BluetoothChatService mChatService = null;
 boolean ACKEnable = false;

 mChatService = new BluetoothChatService(mHandler);
 SendCommand.SendCommandInit(mChatService, mHandler, ACKEnable);


ScanSetLED

Enable or disable the LED indicator for scan success/fail.

Syntax

 Result ScanSetLED(boolean LEDEnable);

Parameters

LEDEnable
    Set to true for LED indication. (default value: true)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 boolean LEDEnable;
 Result result;

 LEDEnable = true;
 result = SendCommand.ScanSetLED(LEDEnable);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetTriggerTimeout

Set scan trigger timeout.

Syntax

 Result ScanSetTriggerTimeout(int TriggerTimeout);

Parameters

TriggerTimeout
    0 ~ 10 seconds. (default value: 3 secs)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int TriggerTimeout;
 Result result;

 TriggerTimeout = 3;
 result = SendCommand.ScanSetTriggerTimeout(TriggerTimeout);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanEnableAutoScan

Enable or disable the auto-scan function.

Syntax

 Result ScanEnableAutoScan(boolean AutoscanEnable);

Parameters

AutoscanEnable
   Set to true in order to scan automatically. (default value: false)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 boolean AutoscanEnable;
 Result result;

 AutoscanEnable = true;
 result = SendCommand.ScanEnableAutoScan(AutoscanEnable);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetAutoScanTimeInterval

Set the time interval of auto-scan.

Syntax

 Result ScanSetAutoScanTimeInterval(int Timeinterval);

Parameters

Timeinterval
   Unit: 250 msec (ex. set Timeinterval to 4 for 1 second, default value: 4)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int Timeinterval;
 Result result;

 Timeinterval = 4; // 1 second
 result = SendCommand.ScanSetAutoScanTimeInterval(Timeinterval);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetPowerSaveMode

Set the power mode of the scanner.

Syntax

 Result SysSetPowerSaveMode(int PowerSaveMode);

Parameters

PowerSaveMode
   [value for N4313]
     0 : Off
     1 : Sleep (default value)
     2 : Hibernate

   [value for SE965HP/SE655/SE4710]
     0 : Normal mode
     1 : Power save mode

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int PowerSaveMode;
 Result result;

 PowerSaveMode = 0;
 result = SendCommand.SysSetPowerSaveMode(PowerSaveMode);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetPowerSaveTimeout

Set the power save timeout of the scanner. (for N4313, SE965HP and SE4710)

Syntax

 Result SysSetPowerSaveTimeout(int PowerSaveTimeout);

Parameters

PowerSaveTimeout
   [value for N4313]
     0 : 1 sec
     1 : 10 secs
     2 : 1 minute
     3 : 5 minutes
     4 : 10 minutes
     5 : 30 minutes
     6 : 60 minutes

   [value for SE965HP]
     0 : 1 sec
     1 : 10 secs
     2 : 1 minute
     3 : 5 minutes
     4 : 15 minutes
     5 : 30 minutes
     6 : 60 minutes

   [value for SE4710]
     0 : 1 sec
     1 : 5 secs
     2 : 1 minute
     3 : 5 minutes
     4 : 15 minutes
     5 : 60 minutes

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int PowerSaveTimeout;
 Result result;

 PowerSaveTimeout = 0; // 1 second for SE965HP
 result = SendCommand.SysSetPowerSaveTimeout(PowerSaveTimeout);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetTerminator

Set the termination character of barcode data.

Syntax

 Result ScanSetTerminator(int Terminator);

Parameters

Terminator
    0 : None (default value)
    1 : CR
    2 : LF
    3 : CR+LF
    4 : Space
    5 : TAB

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int Terminator;
 Result result;

 Terminator = 0;
 result = SendCommand.ScanSetTerminator(Terminator);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetTransmitBarcodeID

Transmit or not the barcode ID.

Syntax

 Result ScanSetTransmitBarcodeID(boolean BarcodeIDEnable);

Parameters

BarcodeIDEnable
   Transmit the predefined barcode ID when true. (default value: false)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 boolean BarcodeIDEnable;
 Result result;

 BarcodeIDEnable = false;
 result = SendCommand.ScanSetTransmitBarcodeID(BarcodeIDEnable);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetPrefixLabel

Transmit or not the prefix lable.

Syntax

 Result ScanSetPrefixLabel(String Prefix);

Parameters

Prefix
   Prefix label string. (default value: null)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 String Prefix;
 Result result;

 Prefix = "a";
 result = SendCommand.ScanSetPrefixLabel(Prefix);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetSuffixLabel

Transmit or not the suffix lable.

Syntax

 Result ScanSetSuffixLabel(String Suffix);

Parameters

Suffix
   Suffix label string. (default value: null)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 String Suffix;
 Result result;

 Prefix = "a";
 result = SendCommand.ScanSetSuffixLabel(Suffix);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetLinearSecurityLevel

Set the linear security level. (for SE965HP and SE655)

Syntax

 Result ScanSetLinearSecurityLevel(int SecurityLevel);

Parameters

SecurityLevel
   1 ~ 4. (defulat value: 1)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int SecurityLevel;
 Result result;

 SecurityLevel = 1;
 result = SendCommand.ScanSetLinearSecurityLevel(SecurityLevel);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetInverse1D

Set the Inverse 1D. (for SE655 and SE4710)

Syntax

 Result ScanSetInverse1D(int Inverse1D);

Parameters

Inverse1D
    0 : Regular Only (default value)
    1 : Inverse Only
    2 : Inverse Autodetect

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int Inverse1D;
 Result result;

 Inverse1D = 0;
 result = SendCommand.ScanSetInverse1D(Inverse1D);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanLock

Lock or unlock the scanner.

Syntax

 Result ScanLock(boolean Lock);

Parameters

ScanLock
   The scanner is locked when true. (default value: false)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 boolean ScanLock;
 Result result;

 ScanLock = false;
 result = SendCommand.ScanLock(ScanLock);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetRedundancyLevel

Set the redundancy level. (for only SE4710)

Syntax

 Result ScanSetRedundancyLevel(int RedundancyLevel);

Parameters

RedundancyLevel
   1 ~ 4. (default value : 1)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int RedundancyLevel;
 Result result;

 RedundancyLevel = 1;
 result = SendCommand.ScanSetRedundancyLevel(RedundancyLevel);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetSecurityLevel

Set the security level. (for only SE4710)

Syntax

 Result ScanSetSecurityLevel(int SecurityLevel);

Parameters

SecurityLevel
   0 ~ 3. (default value : 1)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int SecurityLevel;
 Result result;

 SecurityLevel = 1;
 result = SendCommand.ScanSetSecurityLevel(SecurityLevel);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetPickListMode

Set the picklist mode. (for only SE4710)

Syntax

 Result ScanSetPickListMode(boolean PickListModeEnable);

Parameters

PickListModeEnable
   Enable pick list mode when true. (default value: false)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 boolean PickListModeEnable;
 Result result;

 PickListModeEnable = false;
 result = SendCommand.ScanSetPickListMode(PickListModeEnable);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetScanAngle

Set the scan angle. (for only SE965HP)

Syntax

 Result ScanSetScanAngle(int ScanAngle);

Parameters

ScanAngle
    0 : 10 degree
    1 : 35 degree
    2 : 47 degree

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int ScanAngle;
 Result result;

 ScanAngle = 1;
 result = SendCommand.ScanSetScanAngle(ScanAngle);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetAdaptiveScanning

Set the adaptive scanning. (for only SE965HP)

Syntax

 Result ScanSetAdaptiveScanning(boolean AdaptiveScanningEnable);

Parameters

AdaptiveScanningEnable
   Enable adaptive scanning when true.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 boolean AdaptiveScanningEnable;
 Result result;

 AdaptiveScanningEnable  = true;
 result = SendCommand.ScanSetAdaptiveScanning(AdaptiveScanningEnable);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanEnableSymbologies

Enable or disable Symbologies.

Syntax

 Result ScanEnableSymbologies(int SymEnable0);                   // for N4313, SE965HP and SE655
 Result SE4710EnableSymbologies(int SymEnable0, int SymEnable1); // for only SE4710

Parameters

Symbologies are defined as follows.

SymEnable | SE4710 | N4313 | SE965 | SE655
SymEnable1 | Protocol.UPCE1 | Protocol.UPCE | Protocol.UPCE1 | Protocol.UPCE1
 | Protocol.UPCE | Protocol.UPCA | Protocol.UPCE | Protocol.UPCE
 | Protocol.UPCA | Protocol.TRIOPTIC_TRIOPTICCODE39 | Protocol.UPCA | Protocol.UPCA
 | Protocol.UCCCOUPON | Protocol.TELEPEN | Protocol.UCCCOUPON | Protocol.UCCCOUPON
 | Protocol.TRIOPTIC_TRIOPTICCODE39 | Protocol.STRAIGHT2OF5INDUSTRIAL | Protocol.TRIOPTIC_TRIOPTICCODE39 | Protocol.TRIOPTIC_TRIOPTICCODE39
 | Protocol.MSI | Protocol.STRAIGHT2OF5IATA | Protocol.MSI | Protocol.MSI
 | Protocol.MATRIX2OF5 | Protocol.PLESSEY | Protocol.MATRIX2OF5 | Protocol.MATRIX2OF5
 | Protocol.KOREAN3OF5 | Protocol.NEC2OF5 | Protocol.KOREAN3OF5 | Protocol.ISBT128
 | Protocol.ISBT128 | Protocol.MSI | Protocol.ISBT128 | Protocol.INTERLEAVED2OF5
 | Protocol.INTERLEAVED2OF5 | Protocol.MATRIX2OF5 | Protocol.INTERLEAVED2OF5 | Protocol.GS1DATABARLIMITED
 | Protocol.GS1DATABARLIMITED | Protocol.INTERLEAVED2OF5 | Protocol.GS1DATABARLIMITED | Protocol.GS1DATABAREXPANDED
 | Protocol.GS1DATABAREXPANDED | Protocol.GS1DATABAROMNIDIRECTIONAL | Protocol.GS1DATABAREXPANDED | Protocol.GS1DATABAR14
 | Protocol.GS1DATABAR OMNIDIRECTIONAL | Protocol.GS1DATABARLIMITED | Protocol.GS1DATABAR14 | Protocol.GS1128
 | Protocol.GS1128 | Protocol.GS1DATABAREXPANDED | Protocol.GS1128 | Protocol.EAN8
 | Protocol.EAN8 | Protocol.GS1128 | Protocol.EAN8 | Protocol.EAN13
 | Protocol.EAN13 | Protocol.EAN8 | Protocol.EAN13 | Protocol.DISCRETE2OF5
 | Protocol.CODE93 | Protocol.EAN13 | Protocol.DISCRETE2OF5 | Protocol.CODE93
 | Protocol.CODE39 | Protocol.CODE93 | Protocol.CODE93 | Protocol.CODE39
 | Protocol.CODE128 | Protocol.CODE39 | Protocol.CODE39 | Protocol.CODE128
 | Protocol.CODE11 | Protocol.CODE128 | Protocol.CODE128 | Protocol.CODE11
 | Protocol.CHINESE2OF5 | Protocol.CODE11 | Protocol.CODE11 | Protocol.CHINESE2OF5
 | Protocol.BOOKLAND_EAN | Protocol.CHINA_POST | Protocol.CHINESE2OF5 | Protocol.BOOKLAND_EAN
 | Protocol.CODABAR | Protocol.CODABAR | Protocol.BOOKLAND_EAN | Protocol.CODABAR
 |  |  | Protocol.CODABAR |
SymEnable2 | Protocol.USPOSTNET |  |  |
 | Protocol.USPLANET |  |  |
 | Protocol.UKPOSTAL |  |  |
 | Protocol.JAPANPOSTAL |  |  |
 | Protocol.AUSTRALIAPOST |  |  |
 | Protocol.NETHERLANDSKIXCODE |  |  |
 | Protocol.USPS4CB_ONECODE_INTELLIGENTMAIL |  |  |
 | Protocol.UPUFICSPOSTAL |  |  |
 | Protocol.COMPOSITECCC |  |  |
 | Protocol.COMPOSITECCAB |  |  |
 | Protocol.COMPOSITETLC39 |  |  |
 | Protocol.PDF417 |  |  |
 | Protocol.MICROPDF417 |  |  |
 | Protocol.DATAMATRIX |  |  |
 | Protocol.MAXICODE |  |  |
 | Protocol.QRCODE |  |  |
 | Protocol.MICROQR |  |  |
 | Protocol.AZTEC |  |  |
 | Protocol.HANXIN |  |  |

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Protocol;
import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 // for N4313
 int SymEnable;
 Result result;

 SymEnable = (Protocol.CODABAR | Protocol.BOOKLAND_EAN);

 result = SendCommand.ScanSetEnableSymbologies(SymEnable);
 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetSymbologyOptions (for N4313)

Set the symbology options for N4313 Scanner.

Syntax

 Result ScanSetSymbologyOptions(int symbologyID, byte[] DATA);

Parameters

Symbology | Options | DATA byte order | Comment
Common Options | Barcode ID | DATA [0] | ASCII code
 | Redundancy | DATA [1] | 0 ~ 10 (Set to zero if not used)
 | Length Min | DATA [2] | (Set to zero if not used)
 | Length Max | DATA [3] | (Set to zero if not used)

Symbology | Options | DATA byte order | Comment
CODABAR | Send Start and Stop Character | DATA [4] | 0 - disable 1 - enable
 | Check Character | DATA [5] | 0 - No Check Character 1 - Modulo 16 Check Character 2 - Modulo 7 Check Character 3 - CLSI Check Character
 | Send Check Character | DATA [6] | 0 - disable 1 - enable
 | Codabar Concatenation | DATA [7] | 0 - disable 1 - enable
CODE 39 | Send Start and Stop Character | DATA [4] | 0 - disable 1 - enable
 | No Check Character | DATA [5] | 0 - disable 1 - enable
 | Send Check Character | DATA [6] | 0 - disable 1 - enable
 | Code 32 Pharmaceutical(PARAF) | DATA [7] | 0 - disable 1 - enable
 | Code 39 Full ASCII | DATA [8] | 0 - disable 1 - enable
INTERLEAVED 2 OF 5 | Follett Formatting | DATA [4] | 0 - disable 1 - enable
 | NULL Characters | DATA [5] | 0 - disable 1 - enable
 | No Check Character | DATA [6] | 0 - disable 1 - enable
 | Send Check Character | DATA [7] | 0 - disable 1 - enable
NEC 2 OF 5 | No Check Character | DATA [4] | 0 - disable 1 - enable
 | Send Check Character | DATA [5] | 0 - disable 1 - enable
CODE 93 | - | - |
STRAIGHT 2 OF 5 INDUSTRIAL | - | - |
STRAIGHT 2 OF 5 IATA | - | - |
MATRIX 2 OF 5 | No Check Character | DATA [4] | 0 - disable 1 - enable
 | Send Check Character | DATA [5] | 0 - disable 1 - enable
CODE 11 | Check Character | DATA [4] | 0 - Auto Check Character 1 - One Check Character 2 - Two Check Character
 | Send Check Character | DATA [5] | 0 - disable 1 - enable
CODE 128 | Send Group Separator | DATA [4] | 0 - disable 1 - enable
 | ISBT 128 Enable | DATA [5] | 0 - disable 1 - enable
GS1 128 | Send AI Character | DATA [4] | 0 - disable 1 - enable
TELEPEN | Original Telepen Output | DATA [4] | 0 - disable 1 - enable
UPC A | Send System Character | DATA [4] | 0 - disable 1 - enable
 | Send Check Character | DATA [5] | 0 - disable 1 - enable
 | 2-Digit Addenda | DATA [6] | 0 - disable 1 - enable
 | 5-Digit Addenda | DATA [7] | 0 - disable 1 - enable
 | Addenda Required | DATA [8] | 0 - disable 1 - enable
 | Send Addenda Separator | DATA [9] | 0 - disable 1 - enable
 | UPC-A/EAN-13 with Extended Coupon Code | DATA [10] | 0 - disable 1 - enable
 | Extended Coupon Code Required | DATA [11] | 0 - disable 1 - enable
 | Convert UPC-A to EAN-13 | DATA [12] | 0 - disable 1 - enable
UPC E | Expend | DATA [4] | 0 - disable 1 - enable
 | Send System Character | DATA [5] | 0 - disable 1 - enable
 | Send Check Character | DATA [6] | 0 - disable 1 - enable
 | Enable UPC E0 Leading Zero | DATA [7] | 0 - disable 1 - enable
 | 2-Digit Addenda | DATA [8] | 0 - disable 1 - enable
 | 5-Digit Addenda | DATA [9] | 0 - disable 1 - enable
 | Addenda Required | DATA [10] | 0 - disable 1 - enable
 | Send Addenda Separator | DATA [11] | 0 - disable 1 - enable
EAN 13 | Send Check Character | DATA [4] | 0 - disable 1 - enable
 | 2-Digit Addenda | DATA [5] | 0 - disable 1 - enable
 | 5-Digit Addenda | DATA [6] | 0 - disable 1 - enable
 | Addenda Required | DATA [7] | 0 - disable 1 - enable
 | Send Addenda Separator | DATA [8] | 0 - disable 1 - enable
 | ISBN Enable | DATA [9] | 0 - disable 1 - enable
 | ISSN Enable | DATA [10] | 0 - disable 1 - enable
EAN 8 | Send Check Character | DATA [4] | 0 - disable 1 - enable
 | 2-Digit Addenda | DATA [5] | 0 - disable 1 - enable
 | 5-Digit Addenda | DATA [6] | 0 - disable 1 - enable
 | Addenda Required | DATA [7] | 0 - disable 1 - enable
 | Send Addenda Separator | DATA [8] | 0 - disable 1 - enable
MSI | Check Character | DATA [4] | 0 - Check Character Not Use 1 - Check Character Use One 2 - Check Character Use Two
 | Send Check Character | DATA [5] | 0 - disable 1 - enable
PLESSEY | Send Check Character | DATA [4] | 0 - disable 1 - enable
GS1 DATABAR OMNIDIRECTIONAL | - | - |
GS1 DATABAR LIMITED | - | - |
GS1 DATABAR EXPANDED | - | - |
CHINA POST | - | - |
TRIOPTIC | - | - |

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 byte[] DetailBuffer = null;
 Result result;

 DetailBuffer = new byte[8];

 DetailBuffer[0] = 0;
 DetailBuffer[1] = 0;
 DetailBuffer[2] = 3;
 DetailBuffer[3] = 80;
 DetailBuffer[4] = 0;
 DetailBuffer[5] = 0;
 DetailBuffer[6] = 1;
 DetailBuffer[7] = 1;

 result = SendCommand.ScanSetSymbologiesDetail(1, DetailBuffer);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetSymbologyOptions (for SE965HP)

Set the symbology options for SE965HP Scanner.

Syntax

 Result ScanSetSymbologyOptions(int symbologyID, byte[] DATA);

Parameters

Symbology | Options | DATA byte order | Comment
Common Options | Barcode ID | DATA [0] | ASCII code
 | Length Min | DATA [1] | (Set to zero if not used)
 | Length Max | DATA [2] | (Set to zero if not used)

Symbology | Options | DATA byte order | Comment
UPC A | Send check character | DATA [3] | 0 - disable 1 - enable
 | Send sys_char | DATA [4] | 0 - disable 1 - Send sys_char 2 - Send country_code and sys_char
 | UPC/EAN Supplementals | DATA [5] | 0 - disable 1 - enable
 | UPC/EAN Security Level | DATA [6] | 0 - Security Level 0 1 - Security Level 1 2 - Security Level 2 3 - Security Level 3
UPC E | Send check character | DATA [3] | 0 - disable 1 - enable
 | Convert UPC E to UPC A | DATA [4] | 0 - disable 1 - enable
 | Send sys_char | DATA [5] | 0 - disable 1 - Send sys_char 2 - Send country_code and sys_char
UPC E1 | Send check character | DATA [3] | 0 - disable 1 - enable
 | Convert UPC E1 to UPC A | DATA [4] | 0 - disable 1 - enable
 | Send sys_char | DATA [5] | 0 - disable 1 - Send sys_char 2 - Send country_code and sys_char
EAN 8 | EAN 8 zero extend | DATA [3] | 0 - disable 1 - enable
EAN 13 | - | - |
BOOKLAND EAN | Bookland ISBN Format | DATA [3] | 0 - disable 1 - enable
 | ISSN EAN enable | DATA [4] | 0 - disable 1 - enable
CODE 128 | - | - |
GS1 128(EAN 128) | - | - |
ISBT 128 | Enable ISBT Concatenation | DATA [3] | 0 - disable 1 - enable
 | Enable Check ISBT Table | DATA [4] | 0 - disable 1 - enable
CODE 39 | Convert Code 39 to Code 32 | DATA [3] | 0 - disable 1 - enable
 | Code 32 prefix character(A) | DATA [4] | 0 - disable 1 - enable
 | Check digit | DATA [5] | 0 - disable 1 - enable
 | Send check digit | DATA [6] | 0 - disable 1 - enable
 | Code 39 full ASCII enable | DATA [7] | 0 - disable 1 - enable
TRIOPTIC CODE 39 | - | - |
CODE 93 | - | - |
CODE 11 | Check digit | DATA [3] | 0 - No check digit 1 - One check digit 2 - Two check digit
 | Send check digit | DATA [4] | 0 - disable 1 - enable
INTERLEAVED 2 OF 5 | Check digit | DATA [3] | 0 - No check digit 1 - USS check digit 2 - OPCC check digit
 | Send check digit | DATA [4] | 0 - disable 1 - enable
 | Convert I 2 of 5 to EAN 13 | DATA [5] | 0 - disable 1 - enable
DISCRETE 2 OF 5 | - | - |
CODABAR | CLSI editing | DATA [3] | 0 - disable 1 - enable
 | Strips the start and stop characters | DATA [4] | 0 - disable 1 - enable
 | Upper or lower case start/stop character detection | DATA [5] | 0 - disable 1 - enable
MSI | Enable TWO CD/Disable ONE CD | DATA [3] | 0 - disable 1 - enable
 | Send check digit | DATA [4] | 0 - disable 1 - enable
 | Enable MOD 10/MOD 10/Disable MOD 10/MOD 11 | DATA [5] | 0 - disable 1 - enable
GS1 DATABAR 14 | Convert GS1 DataBar to UPC/EAN | DATA [3] | 0 - disable 1 - enable
GS1 DATABAR LIMITED | GS1 DataBar Limited Security level | DATA [3] | 0 - Security level 1 1 - Security level 2 2 - Security level 3 3 - Security level 4
GS1 DATABAR EXPANDED | - | - |
UCC COUPON | Coupon Symbols | DATA [3] | 0 - Old Coupon Symbols 1 - New Coupon Symbols 2 - Both Coupon Symbols
CHINESE 2 OF 5 | - | - |
MATRIX 2 OF 5 | Check digit | DATA [3] | 0 - disable 1 - enable
 | Send check digit | DATA [4] | 0 - disable 1 - enable
KOREAN 3 OF 5 | - | - |

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 byte[] DetailBuffer = null;
 Result result;

 DetailBuffer = new byte[6];

 DetailBuffer[0] = 0;
 DetailBuffer[1] = 3;
 DetailBuffer[2] = 80;
 DetailBuffer[3] = 0;
 DetailBuffer[4] = 0;
 DetailBuffer[5] = 0;

 result = SendCommand.ScanSetSymbologiesDetail(1, DetailBuffer);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetSymbologyOptions (for SE655)

Set the symbology options for SE655 Scanner.

Syntax

 Result ScanSetSymbologyOptions(int symbologyID, byte[] DATA);

Parameters

Symbology | Options | DATA byte order | Comment
Common Options | Barcode ID | DATA [0] | ASCII code
 | Length Min | DATA [1] | (Set to zero if not used)
 | Length Max | DATA [2] | (Set to zero if not used)

Symbology | Options | DATA byte order | Comment
UPC A | Send check character | DATA [3] | 0 - disable 1 - enable
 | Send sys_char | DATA [4] | 0 - disable 1 - Send sys_char 2 - Send country_code and sys_char
 | UPC/EAN Supplementals | DATA [5] | 0 - disable 1 - enable
 | UPC/EAN Security Level | DATA [6] | 0 - Security Level 0 1 - Security Level 1 2 - Security Level 2 3 - Security Level 3
UPC E | Send check character | DATA [3] | 0 - disable 1 - enable
 | Convert UPC E to UPC A | DATA [4] | 0 - disable 1 - enable
 | Send sys_char | DATA [5] | 0 - disable 1 - Send sys_char 2 - Send country_code and sys_char
UPC E1 | Send check character | DATA [3] | 0 - disable 1 - enable
 | Convert UPC E1 to UPC A | DATA [4] | 0 - disable 1 - enable
 | Send sys_char | DATA [5] | 0 - disable 1 - Send sys_char 2 - Send country_code and sys_char
EAN 8 | EAN 8 zero extend | DATA [3] | 0 - disable 1 - enable
EAN 13 | - | - |
BOOKLAND EAN | ISSN enable | DATA [3] | 0 - disable 1 - enable
 | Bookland ISBN Format | DATA [4] | 0 - disable 1 - enable
CODE 128 | - | - |
GS1 128(EAN 128) | - | - |
ISBT 128 | ISBT Concatenation | DATA [3] | 0 - disable 1 - enable
 | Check ISBT Table | DATA [4] | 0 - disable 1 - enable
CODE 39 | Convert Code 39 to Code 32 | DATA [3] | 0 - disable 1 - enable
 | Code 32 prefix character(A) | DATA [4] | 0 - disable 1 - enable
 | Check digit | DATA [5] | 0 - disable 1 - enable
 | Send check digit | DATA [6] | 0 - disable 1 - enable
 | Code 39 full ASCII enable | DATA [7] | 0 - disable 1 - enable
TRIOPTIC CODE 39 | - | - |
CODE 93 | - | - |
CODE 11 | Check digit | DATA [3] | 0 - No check digit 1 - One check digit 2 - Two check digit
 | Send check digit | DATA [4] | 0 - disable 1 - enable
INTERLEAVED 2 OF 5 | Check digit | DATA [3] | 0 - No check digit 1 - USS check digit 2 - OPCC check digit
 | Send check digit | DATA [4] | 0 - disable 1 - enable
 | Convert I 2 of 5 to EAN 13 | DATA [5] | 0 - disable 1 - enable
DISCRETE 2 OF 5 | - | - |
CODABAR | CLSI editing | DATA [3] | 0 - disable 1 - enable
 | Strips the start and stop characters | DATA [4] | 0 - disable 1 - enable
MSI | Enable TWO CD/Disable ONE CD | DATA [3] | 0 - disable 1 - enable
 | Send check digit | DATA [4] | 0 - disable 1 - enable
 | Enable MOD 10/MOD 10/Disable MOD 10/MOD 11 | DATA [5] | 0 - disable 1 - enable
GS1 DATABAR 14 | Convert GS1 DataBar to UPC/EAN | DATA [3] | 0 - disable 1 - enable
GS1 DATABAR LIMITED | - | - |
GS1 DATABAR EXPANDED | - | - |
UCC COUPON | - | - |
CHINESE 2 OF 5 | - | - |
MATRIX 2 OF 5 | Check digit | DATA [3] | 0 - disable 1 - enable
 | Send check digit | DATA [4] | 0 - disable 1 - enable
 | Redundancy enable | DATA [5] | 0 - disable 1 - enable

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 byte[] DetailBuffer = null;
 Result result;

 DetailBuffer = new byte[5];

 DetailBuffer[0] = 0;
 DetailBuffer[1] = 3;
 DetailBuffer[2] = 80;
 DetailBuffer[3] = 0;
 DetailBuffer[4] = 0;

 result = SendCommand.ScanSetSymbologiesDetail(1, DetailBuffer);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetSymbologyOptions (for SE4710)

Set the symbology options for SE4710 Scanner.

Syntax

 Result ScanSetSymbologyOptions(int symbologyID, byte[] DATA);

Parameters

Symbology | Options | DATA byte order | Comment
Common Options | Barcode ID | DATA [0] | ASCII code
 | Length Min | DATA [1] | (Set to zero if not used)
 | Length Max | DATA [2] | (Set to zero if not used)

Symbology | Options | DATA byte order | Comment
UPC A | Send check character | DATA [3] | 0 - disable 1 - enable
 | Send sys_char | DATA [4] | 0 - disable 1 - Send sys_char 2 - Send country_code and sys_char
 | UPC/EAN Supplementals | DATA [5] | 0 - disable 1 - enable
UPC E | Send check character | DATA [3] | 0 - disable 1 - enable
 | Convert UPC E to UPC A | DATA [4] | 0 - disable 1 - enable
 | Send sys_char | DATA [5] | 0 - disable 1 - Send sys_char 2 - Send country_code and sys_char
UPC E1 | Send check character | DATA [3] | 0 - disable 1 - enable
 | Convert UPC E1 to UPC A | DATA [4] | 0 - disable 1 - enable
 | Send sys_char | DATA [5] | 0 - disable 1 - Send sys_char 2 - Send country_code and sys_char
EAN 8 | EAN 8 zero extend | DATA [3] | 0 - disable 1 - enable
EAN 13 | - | - |
BOOKLAND EAN | ISSN enable | DATA [3] | 0 - disable 1 - enable
 | Bookland ISBN Format | DATA [4] | 0 - disable 1 - enable
CODE 128 | - | - |
GS1 128(EAN 128) | - | - |
ISBT 128 | ISBT Concatenation | DATA [3] | 0 - disable 1 - enable
 | Check ISBT Table | DATA [4] | 0 - disable 1 - enable
CODE 39 | Convert Code 39 to Code 32 | DATA [3] | 0 - disable 1 - enable
 | Code 32 prefix character(A) | DATA [4] | 0 - disable 1 - enable
 | Check digit | DATA [5] | 0 - disable 1 - enable
 | Send check digit | DATA [6] | 0 - disable 1 - enable
 | Code 39 full ASCII enable | DATA [7] | 0 - disable 1 - enable
TRIOPTIC CODE 39 | - | - |
CODE 93 | - | - |
CODE 11 | Check digit | DATA [3] | 0 - No check digit 1 - One check digit 2 - Two check digit
 | Send check digit | DATA [4] | 0 - disable 1 - enable
INTERLEAVED 2 OF 5 | Check digit | DATA [3] | 0 - No check digit 1 - USS check digit 2 - OPCC check digit
 | Send check digit | DATA [4] | 0 - disable 1 - enable
 | Convert I 2 of 5 to EAN 13 | DATA [5] | 0 - disable 1 - enable
DISCRETE 2 OF 5 | - | - |
CODABAR | CLSI editing | DATA [3] | 0 - disable 1 - enable
 | Strips the start and stop characters | DATA [4] | 0 - disable 1 - enable
 | Codabar Upper or Lower Case Start/Stop Characters Detection | DATA [5] | 0 - upper case 1 - lower case
MSI | Enable TWO CD/Disable ONE CD | DATA [3] | 0 - disable 1 - enable
 | Send check digit | DATA [4] | 0 - disable 1 - enable
 | Enable MOD 10/MOD 10/Disable MOD 10/MOD 11 | DATA [5] | 0 - disable 1 - enable
GS1 DATABAR Omnidirectional | Convert GS1 DataBar to UPC/EAN | DATA [3] | 0 - disable 1 - enable
GS1 DATABAR LIMITED | GS1 DataBar Limited Security Level | DATA [3] | 1 ~ 4
GS1 DATABAR EXPANDED | - | - |
UCC COUPON | Coupon Symbols | DATA [3] | 0 - Old Coupon Symbols 1 - New Coupon Symbols 2 - Both Coupon Symbols
CHINESE 2 OF 5 | - | - |
MATRIX 2 OF 5 | Check digit | DATA [3] | 0 - disable 1 - enable
 | Send check digit | DATA [4] | 0 - disable 1 - enable
KOREAN 3 of 5 | - | - |
US POSTNET | Send check digit | DATA [3] | 0 - disable 1 - enable
US PLANET | Send check digit | DATA [3] | 0 - disable 1 - enable
US POSTAL | Send check digit | DATA [3] | 0 - disable 1 - enable
JAPAN POSTAL | - | - |
AUSTRALIA POST | Australia Post Format | DATA [3] | 0 ~ 3
NETHERLANDS KIX CODE | - | - |
USPS 4CB/ONE CODE/INTELLIGENT MAIL | - | - |
UPU FICS POSTAL | - | - |
COMPOSITE CC-C | - | - |
COMPOSITE CC-A/B | UPC Composite Mode | DATA [3] | 0 ~ 2
COMPOSITE TLC-39 | - | - |
PDF417 | - | - |
MICROPDF417 | - | - |
DATA MATRIX | Data Matrix Inverse | DATA [3] | 0 ~ 2
 | Decode Mirror Images | DATA [4] | 0 ~ 2
MAXICODE | - | - |
QR CODE | QR Inverse | DATA [3] | 0 ~ 2
MICRO QR | - | - |
AZTEC | Aztec Inverse | DATA [3] | 0 ~ 2
HAN XIN | Han Xin Inverse | DATA [3] | 0 - Regular 1 - Inverse Only 2 - Inverse Autodetect

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 byte[] DetailBuffer = null;
 Result result;

 DetailBuffer = new byte[6];

 DetailBuffer[0] = 0;
 DetailBuffer[1] = 3;
 DetailBuffer[2] = 80;
 DetailBuffer[3] = 0;
 DetailBuffer[4] = 0;
 DetailBuffer[5] = 0;

 result = SendCommand.ScanSetSymbologiesDetail(1, DetailBuffer);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


ScanSetTrigger

Enable the scan beam.

Syntax

 Result ScanSetTrigger();

Parameters

None.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 public class MainActivity extends Activity {
   public static final int MESSAGE_BARCODE = 2;
   ...

    {
     ...
    Result result;
    result = ScanSetTrigger();

    if (result == Result.Fail) {
      // Fail
    } else if (result == Result.NotConnected) {
      // Not connected
    } else if (result == Result.Timeout) {
      // Timeout
    }
    ...
    }

    private final Handler mHandler = new Handler() {
    @Override
    public void handleMessage(Message msg) {
       switch (msg.what) {
       case MESSAGE_BARCODE :
          byte[] BarcodeBuff = (byte[]) msg.obj;
          String Barcode = "";
          Barcode = new String(BarcodeBuff, 0, msg.arg1);
          break;
       }
   }
  };

  ...


GPSSetPower

Power on or off the GPS module.

Syntax

 Result GPSSetPower(int PowerEnable);

Parameters

PowerEnable
    0 : power off
    1 : power on

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int PowerEnable;
 Result result;

 PowerEnable = 1; // power on
 result = SendCommand.GPSSetPower(PowerEnable);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


GPSReset

Reset the GPS module.

Syntax

 Result GPSReset();

Parameters

None.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 Result result;

 result = SendCommand.GPSReset();

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


GPSSetBypassData

Enable or disable the GPS bypass data.

Syntax

 Result GPSSetBypassData(boolean BypassEnable);

Parameters

BypassEnable
   Set to true for bypass data enable, set to false for disable.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 boolean BypassEnable;
 Result result;

 BypassEnable = true;
 result = SendCommand.GPSSetBypassData(BypassEnable);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


NFCSetPower

Turn on or off the NFC module.

Syntax

 Result NFCSetPower(int PowerEnable);

Parameters

PowerEnable
    0 : power off
    1 : power on

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int PowerEnable;
 Result result;

 PowerEnable = 1;
 result = SendCommand.NFCSetPower(PowerEnable);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


NFCEnableAutoDetect

Enable or disable the NFC auto detect.

Syntax

 Result NFCEnableAutoDetect(boolean AutoDetect);

Parameters

AutoDetect
   Set to true for NFC auto detect enable, set to false for disable.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 boolean AutoDetect;
 Result result;

 AutoDetect = true;
 result = SendCommand.NFCEnableAutoDetect(AutoDetect);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


NFCEnableTagType

Enable the corresponding tag type to be detected.

Syntax

 Result NFCEnableTagType(int TagType);

Parameters

TagType
   Tag type to be detected.
      0x01 : Mifare
      0x02 : ISO15693 (Not supported)
      0x04 : Type A
      0x08 : Type B
      0x10 : Felica (Not Supported)
      0x1F : ALL

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int TagType;
 Result result;

 TagType = 1; //Mifare Enable
 result = SendCommand.NFCEnableTagType(TagType);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


NFCGetDetectInfo

Get the detected tag information.

Syntax

 byte[] NFCGetDetectInfo();

Parameters

None.

Return Value

Return Type | Buffer byte order | Description
byte[] | byte[0] | Tag Type 0x01 : Mifare Ultralight 0x02 : Mifare UltralightC 0x03 : Mifare Classic 0x04 : Mifare Classic 1k 0x05 : Mifare Classic 4k 0x06 : Mifare plus 0x07 : Mifare plus 2k sl1 0x08 : Mifare plus 4k sl1 0x09 : Mifare plus 2k sl2 0x0A : Mifare plus 4k sl2 0x0B : Mifare plus 2k sl3 0x0C : Mifare plus 4k sl3 0x0D : Mifare DESFire 0x0F : JCOP 0x10 : Mifare Mini 0x11 : nPA 0xA0 : ISO15693 0xB0 : Type A 0xC0 : Type B 0xD0 : Felica
 | byte[1:n] | UID Informataion

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

Notification NFC.

Example

 byte[] DetectInfo;

 DetectInfo = SendCommand.NFCGetDetectInfo();

 if ((DetectInfo[0] == 0x03
   ||(DetectInfo[0] == 0x04)
   ||(DetectInfo[0] == 0x05)) { //Mifare Classic

   byte[] MifareClassicUID = new byte[DetectInfo.length-1];

   for(int i = 0; i < (DetectInfo.length-1); i++) {
    MifareClassicUID[i] = DetectInfo[i+1];
   }
 }
 else if(DetectInfo[0] == 0x0f) { //jcop
  byte[] TypeAUID = new byte[DetectInfo.length-1];

  for(int i = 0; i < (DetectInfo.length-1); i++) {
   TypeAUID[i] = DetectInfo[i+1];
  }
 }
 else if(DetectInfo[0] == (byte)0xc0) { //Type B
   byte[] TypeBUID = new byte[DetectInfo.length-1];

   for(int i = 0; i < (DetectInfo.length-1); i++) {
    TypeBUID[i] = DetectInfo[i+1];
   }
 }
 else if((DetectInfo[0] == 0x01)        //Mifare Ultralight
      || (DetectInfo[0] == 0x02)        //Mifare UltralightC
      || (DetectInfo[0] == 0x04)        //Mifare Classic 1k
      || (DetectInfo[0] == 0x05)        //Mifare Classic 4k
      || (DetectInfo[0] == 0x06)        //Mifare plus
      || (DetectInfo[0] == 0x07)        //Mifare plus 2k sl1
      || (DetectInfo[0] == 0x08)        //Mifare plus 4k sl1
      || (DetectInfo[0] == 0x09)        //Mifare plus 2k sl2
      || (DetectInfo[0] == 0x0a)        //Mifare plus 4k sl2
      || (DetectInfo[0] == 0x0b)        //Mifare plus 2k sl3
      || (DetectInfo[0] == 0x0c)        //Mifare plus 4k sl3
      || (DetectInfo[0] == 0x0d)        //Mifare DESFire
      || (DetectInfo[0] == 0x10)        //Mifare Mini
      || (DetectInfo[0] == 0x11)        //nPA
      || (DetectInfo[0] == (byte)0xa0)  //ISO15693
      || (DetectInfo[0] == (byte)0xb0)  //Type A
      || (DetectInfo[0] == (byte)0xd0)) //Felica) {
   byte[] UIDData = new byte[DetectInfo.length-1];

   for(int i = 0; i < (DetectInfo.length-1); i++) {
    UIDData[i] = DetectInfo[i+1];


NFCMifareClassicSetKey

Set the key for Mifare classic tag.

Syntax

 Result NFCMifareClassicSetKey(byte[] SetKey);

Parameters

SetKey
  Set to store key data.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

Notification NFC.
NFCReadComplete.

Example

 byte[] SetKey = new byte[6];
 Result result;

 SetKey[0] = 0x41;
 SetKey[1] = 0x4D;
 SetKey[2] = 0x43;
 SetKey[3] = 0x45;
 SetKey[4] = 0x4D;
 SetKey[5] = 0x43;
 result = SendCommand.NFCMifareClassicSetKey(SetKey);
 if (result == Result.Fail) {
   // Fail
   SendCommand.NFCReadComplete();
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


NFCMifareClassicAuthenticateBlock

Authenticate the corresponding block for Mifare classic tag.

Syntax

 Result NFCMifareClassicAuthenticateBlock(int AuthBlock, byte SelectTypeAB);

Parameters

AuthBlock
   Number of block to be authenticated.

SelectTypeAB
   Select authenticate Block Type. (TypeA : 0x0a, TypeB : 0x0b)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

Notification NFC.
NFCReadComplete.

Example

 int AuthBlock;
 byte SelectTypeAB;
 Result result;

 AuthBlock = 1;
 SelectTypeAB = 0x0a;
 result = SendCommand.NFCMifareClassicAuthenticateBlock(AuthBlock, SelectTypeAB);
 if (result == Result.Fail) {
   // Fail
   SendCommand.NFCReadComplete();
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


NFCMifareClassicAuthenticateSector

Authenticate the corresponding sector for Mifare classic tag.

Syntax

 Result NFCMifareClassicAuthenticateSector(int AuthSector, byte SelectTypeAB);

Parameters

AuthSector
   Number of sector to be authenticated.

SelectTypeAB
   Select authenticate Sector Type. (TypeA : 0x0a, TypeB : 0x0b)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

Notification NFC.
NFCReadComplete.

Example

 int AuthSector;
 byte SelectTypeAB;
 Result result;

 AuthSector = 2;
 SelectTypeAB = 0x0a;
 result = SendCommand.NFCMifareClassicAuthenticateSector(AuthSector, SelectTypeAB);
 if (result == Result.Fail) {
   // Fail
   SendCommand.NFCReadComplete();
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


NFCMifareClassicReadBlock

Read the block for Mifare classic tag.

Syntax

 byte[] NFCMifareClassicReadBlock(int ReadBlock);

Parameters

ReadBlock
   Number of block to be read.

Return Value

Receive a data.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

Notification NFC.
NFCReadComplete.

Example

 int ReadBlock;
 byte[] ReadData;

 ReadBlock = 2;
 ReadData = SendCommand.NFCMifareClassicAuthenticateBlock(ReadBlock);
 SendCommand.NFCReadComplete();


NFCMifareClassicReadSector

Read the sector for Mifare classic tag.

Syntax

 byte[] NFCMifareClassicReadSector(int ReadSector);

Parameters

ReadBlock
   Number of sector to be read.

Return Value

Receive a data.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

Notification NFC.
NFCReadComplete.

Example

 int ReadSector;
 byte[] ReadData;

 ReadSector = 2;
 ReadData = SendCommand.NFCMifareClassicAuthenticateSector(ReadSector);
 SendCommand.NFCReadComplete();


NFCTypeADataExchange

Data exchange for Type A tag.

Syntax

 byte[] NFCTypeADataExchange(byte[] APDU);

Parameters

APDU
   Contains APDU command.

Return Value

Receive a data.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

Notification NFC.
NFCReadComplete.

Example

 byte[] APDU = new byte[13];
 byte[] TypeAData;

 APDU[0]  = 0x00;
 APDU[1]  = 0xA4;
 APDU[2]  = 0x04;
 APDU[3]  = 0x00;
 APDU[4]  = 0x07;
 APDU[5]  = 0xD4;
 APDU[6]  = 0x10;
 APDU[7]  = 0x65;
 APDU[8]  = 0x09;
 APDU[9]  = 0x90;
 APDU[10] = 0x00;
 APDU[11] = 0x20;
 APDU[12] = 0x00;

 TypeAData = SendCommand.NFCTypeADataExchange(APDU);


NFCTypeBDataExchange

Data exchange for Type B tag.

Syntax

 byte[] NFCTypeBDataExchange(byte[] APDU);

Parameters

APDU
   Contains APDU command.

Return Value

Receive a data.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

Notification NFC.
NFCReadComplete.

Example

 byte[] APDU = new byte[13];
 byte[] TypeBData;

 APDU[0]  = 0x00;
 APDU[1]  = 0xA4;
 APDU[2]  = 0x04;
 APDU[3]  = 0x00;
 APDU[4]  = 0x07;
 APDU[5]  = 0xD4;
 APDU[6]  = 0x10;
 APDU[7]  = 0x65;
 APDU[8]  = 0x09;
 APDU[9]  = 0x90;
 APDU[10] = 0x00;
 APDU[11] = 0x20;
 APDU[12] = 0x00;

 TypeBData = SendCommand.NFCTypeBDataExchange(APDU);


NFCReadComplete

Notify that tag reading operation is completed.

Syntax

 Result NFCReadComplete();

Parameters

None.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

Notification NFC.

Example

 Result result;

 result = SendCommand.NFCReadComplete();

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


System

Copyright 2014 Pointmobile Corporation


SysSetBeepVolume

Set the beep volume.

Syntax

 Result SysSetBeepVolume(int BeepVolume);

Parameters

BeepVolume
    0 : None
    1 : Low
    2 : Middle
    3 : High

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int BeepVolume;
 Result result;

 BeepVolume = 0;
 result = SendCommand.SysSetBeepVolume(BeepVolume);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


SysSetDateTime

Set the date and time of the Bluetooth scanner.

Syntax

 Result SysSetDateTime(String DateTime);

Parameters

DateTime
   String format : yyyyMMddHHmmss. (yyyy: year, MM: month, dd: day, HH: hour, mm: minute, ss: second)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 long now = System.currentTimeMillis();
 Date date = new Date(now);

 SimpleDateFormat sdfNow = new SimpleDateFormat("yyyyMMddHHmmss");
 String strNow = sdfNow.format(date);

 Result result = SendCommand.SysSetDateTime(strNow);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


SysSetButtonLock

Lock or unlock the buttons.

Syntax

 Result SysSetButtonLock(boolean ButtonLock);

Parameters

ButtonLockEnable
   The buttons are locked when true. (default value: false)

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 boolean ButtonLock;
 Result result;

 ButtonLock = false;
 result = SendCommand.SysSetButtonLock(ButtonLockEnable);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


SysFactoryReset

Set all the settings to the factory default and reset the device.

Syntax

 Result SysFactoryReset();

Parameters

None.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 Result result;
 result = SendCommand.SysFactoryReset();

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


SysSetScanSuccessVibration

Set the vibration on scan success.

Syntax

 Result SysSetScanSuccessVibration(int VibraotorSuccess);

Parameters

VibraotorSuccess
    0 : Disable
    1 : Short
    2 : Middle
    3 : Long

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int VibraotorSuccess;
 Result result;

 VibraotorSuccess = 0;
 result = SendCommand.SysSetScanSuccessVibration(VibraotorSuccess);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


SysSetScanFailVibration

Set the vibration on scan fail.

Syntax

 Result SysSetScanFailVibration(int VibraotorFail);

Parameters

VibraotorFail
    0 : Disable
    1 : Short
    2 : Middle
    3 : Long

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int VibraotorFail;
 Result result;

 VibraotorSuccess = 0;
 result = SendCommand.SysSetScanFailVibration(VibraotorFail);

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


SysResetMemory

Erase all the barcode data in the flash memory.

Syntax

 Result SysResetMemory();

Parameters

None.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 Result result;

 result = SendCommand.SysResetMemory();

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout


SysSetAlertMessage

Alert or notify with beep, vibration and text message.

Syntax

 Result SysSetAlertMessage(int BeepType, int VibratorInterval, String SecondLine, String ThirdLine)

Parameters

BeepType
   0 - No Beep
   1 - Beep Type 1 (Scan Successful)
   2 - Beep Type 2 (Scan Failed)
   3 - Beep Type 3 (Scan Duplicated)
   4 - Beep Type 4 (Scan Locked)

VibratorInterval
   Duration of vibration. The unit of time is 100msec. (ex. integer 10 means one second).

SecondLine
   Text message which is displayed at first line(max length is 13 characters in English).

ThirdLine
   Text message which is displayed at second line(max length is 13 characters in English).

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int BeepType = 1;
 int VibratorInterval = 10;
 String SecondLine = "Hello";
 String ThirdLine  = "World";

 Result result;

 result = SysSetAlertMessage(BeepType, VibratorInterval, SecondLine, ThirdLine);

 if(result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout){
   // Timeout


SysSetAlertMessageEx

Alert or notify with beep, vibration and extended text message.

Syntax

 Result SysSetAlertMessageEx(int BeepType, int VibratorInterval, String FirtstLine, String SecondLine, String ThirdLine, String FourthLine)

Parameters

BeepType
   0 - No Beep
   1 - Beep Type 1 (Scan Successful)
   2 - Beep Type 2 (Scan Failed)
   3 - Beep Type 3 (Scan Duplicated)
   4 - Beep Type 4 (Scan Locked)

VibratorInterval
   Duration of vibration. The unit of time is 100msec. (ex. integer 10 means one second).

FirtstLine
   Text message which is displayed at first line(max length is 13 characters in English).

SecondLine
   Text message which is displayed at second line(max length is 13 characters in English).

ThirdLine
   Text message which is displayed at second line(max length is 13 characters in English).

FourthLine
   Text message which is displayed at second line(max length is 13 characters in English).

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int BeepType = 1;
 int VibratorInterval = 10;
 String FirtstLine = "Hello";
 String SecondLine = "World";
 String ThirdLine  = "Pointmobile";
 String FourthLine = "World";

 Result result;

 result = SysSetAlertMessage(BeepType, VibratorInterval, FirtstLine, SecondLine, ThirdLine, FourthLine);

 if(result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout){
   // Timeout


BTGetMACAddress

Get the MAC address of the Bluetooth module in the device.

Syntax

 String BTGetMACAddress();

Parameters

None.

Return Value

MAC Address.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 String MACAdress;

 MACAdress = SendCommand.BTGetMACAddress();
 if (MACAdress == null) {
   // ...


BTGetFWVersion

Get the firmware version of the Bluetooth module in the device.

Syntax

 String BTGetFWVersion();

Parameters

None.

Return Value

Firmware version of the Bluetooth module.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 String FWVersion;

 FWVersion = SendCommand.BTGetFWVersion();
 if (FWVersion == null) {
   // ..


NFCGetFWVersion

Get the firmware version of the NFC module in the device.

Syntax

 String NFCGetFWVersion();

Parameters

None.

Return Value

Firmware version of the NFC module.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 String FWVersion;

 FWVersion = SendCommand.NFCGetFWVersion();
 if (FWVersion == null) {
   // ..


SysGetNumberOfStoredBarcodes

Get the number of the stored bardcode data.

Syntax

 int SysGetNumberOfStoredBarcodes();

Parameters

None.

Return Value

The number of data.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int StoredBarcodes;

 StoredBarcodes = SendCommand.SysGetNumberOfStoredBarcodes();


SysGetFreeMemory

Get the available memory in the device (KBytes).

Syntax

 int SysGetFreeMemory();

Parameters

None.

Return Value

Available memory (KBytes).

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int FreeMemory;

 FreeMemory = SendCommand.SysGetFreeMemory();


SysGetBatteryStatus

Get the battery status (%).

Syntax

 int SysGetBatteryStatus();

Parameters

None.

Return Value

Capacity remaining (%).

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int Availablebattery;

 Availablebattery = SendCommand.SysGetBatteryStatus();


SysGetDeviceFWVersion

Get the firmware version of the device.

Syntax

 String SysGetDeviceFWVersion();

Parameters

None.

Return Value

Firmware version of the Device.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 String FWVersion;

 FWVersion = SendCommand.SysGetDeviceFWVersion();
 if (FWVersion == null) {
   // ...


SysGetDeviceSerialNumber

Get the serial number of the device.

Syntax

 String SysGetDeviceSerialNumber();

Parameters

None.

Return Value

Serial number of the device.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 String DeviceSN;

 DeviceSN = SendCommand.SysGetDeviceSerialNumber();
 if (DeviceSN == null) {
   // ...


SysGetScannerType

Get the equipped scanner type.

Syntax

 int SysGetScannerType();

Parameters

None.

Return Value

Scanner Type
   1 : N4313
   2 : SE965HP
   3 : SE655
   4 : SE4710

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 int Scannertype;

 Scannertype = SendCommand.SysGetScannerType();


SysGetPartNumber

Get the part number of the Bluetooth scanner.

Syntax

 String SysGetPartNumber();

Parameters

None.

Return Value

Part number of the device.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 String PartNumber;

 PartNumber = SendCommand.SysGetPartNumber();
 if (PartNumber == null) {
   // ...


SysSetDeviceSettings

Device Clone Utility: Set all the settings to the device.

Syntax

 Result SysSetDeviceSettings(String Settings);

Parameters

Settings
   The device settings which should be the return value of SysGetDeviceSettings()

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 public static String SettingsData;

 private void LoadSelections() {
     SharedPreferences settingsActivity = getSharedPreferences("SystemUtilityConfig_detail", Activity.MODE_PRIVATE);

     if (settingsActivity.contains("SystemUtilityConfig_detailsave")) {
      String savedItems = settingsActivity.getString("SystemUtilityConfig_detailsave", "");
      String[] splitData = savedItems.split(",");

      SettingsData = splitData[0];

     }
 }
 .....
 {
      ...
      LoadSelections();
      result = SendCommand.SysSetDeviceSettings(SettingsData);

      if (result == Result.Fail) {
        // Fail
      } else if (result == Result.NotConnected) {
        // Not connected
      } else if (result == Result.Timeout) {
        // Timeout
      }
      ...


SysGetDeviceSettings

Device Clone Utility: Get all the settings from the device.

Syntax

 String SysGetDeviceSettings();

Parameters

None.

Return Value

Binary data of the device settings.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 public static String SettingsData;

 private void SaveSelections() {
  SharedPreferences settingsActivity = getSharedPreferences("SystemUtilityConfig_detail", Activity.MODE_PRIVATE);
   SharedPreferences.Editor prefEditor = settingsActivity.edit();
   String savedItems = getSavedItems();

   prefEditor.putString("SystemUtilityConfig_detailsave" , savedItems);
   prefEditor.commit();
 }

 private String getSavedItems() {
   String savedItems = "";
   savedItems = SettingsData;

   return savedItems;

 }

.....

 {
     ...
     boolean String DeviceSettings = SendCommand.SysGetDeviceSettings();

     if(DeviceSettings != null)
     {
        SettingsData= DeviceSettings;
        SaveSelections();
     }
     ...


SysRequestAllScanData

Request all the bardcode data.Each data will be transmitted by notification.
The data format is defined as follows. This format is like CSV(comma-seperated value)
Barcode data,Symbology type,Date,Time,Latitude,Longitude.

Syntax

 Result SysRequestAllScanData();

Parameters

None.

Return Value

If successful, returns a Result.Success.
If unsuccessful, returns a Result.Fail.
If the command is timeout, returns a Result.Timeout.
If bluetooth not connected, returns a Result.NotConnected.

Requirements

Import import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;
Library PM3SDK.jar

See Also

None.

Example

 Result result;
 result = SendCommand.SysRequestAllScanData();

 if (result == Result.Fail) {
   // Fail
 } else if (result == Result.NotConnected) {
   // Not connected
 } else if (result == Result.Timeout) {
   // Timeout
 }

 //MainActivity
  public static final int MESSAGE_BATCH = 15;

  private final Handler mHandler = new Handler() {
  @Override
  public void handleMessage(Message msg) {
   switch (msg.what) {
   case MESSAGE_BATCH:
    PMSyncMemberVariable.StartBatchJob = true;
    byte[] BactchBuf = (byte[]) msg.obj;
    String BactchMsg = "";
    BactchMsg = new String(BactchBuf, 0, msg.arg1);
    if(!(BactchBuf[0] == 0x3c)) {
     BARCODE_TOTAL++;
     TotalCount.setText("Total : "+ BARCODE_TOTAL);
    } else {
     PMSyncMemberVariable.StartBatchJob = false;
    }
    mConversationArrayAdapter.add(BactchMsg);
    break;
   }
  }
 };


Notification

Android >
Notification

Notification Data

Description
Get the Barcode data, NFC tag information or Keyevent by notification.

Requirements

Import

import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;

Library PM3SDK.jar


Barcode

Description
Get the Barcode data.

Example

 public class MainActivity extends Activity {
    public static final int MESSAGE_BARCODE = 2;
 ...

    private final Handler mHandler = new Handler() {
    @Override
    public void handleMessage(Message msg) {
       switch (msg.what) {
       case MESSAGE_BARCODE :
          byte[] BarcodeBuff = (byte[]) msg.obj;
          String Barcode = "";
          Barcode = new String(BarcodeBuff, 0, msg.arg1);
          break;
       }
   }
  };

 ...
 }

See Also

None.

Requirements

Import

import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;

Library PM3SDK.jar


NFC

Description
Get the type and UID of NFC tag.

Example

 public class MainActivity extends Activity {
    public static final int MESSAGE_NFC = 16;
 ...

    private final Handler mHandler = new Handler() {
    @Override
    public void handleMessage(Message msg) {
       switch (msg.what) {
       case MESSAGE_NFC :
          byte[] NFCbuff = (byte[]) msg.obj;
          Result result;

          if(NFCbuff[0] == 0x03  //Mifare Classic
          || NFCbuff[0] == 0x04  //Mifare Classic 1k
          || NFCbuff[0] == 0x05) //Mifare Classic 4k
          {
              byte[] MifareUID = new byte[NFCbuff.length-1];

              for(int i = 0; i < (NFCbuff.length-1); i++) {
                 MifareUID[i] = NFCbuff[i+1]; // Mifare UID Data
              }

              byte NFC_KeyStore[] = {0x41, 0x4D, 0x43, 0x45, 0x4D, 0x43};
              result = SendCommand.NFCMifareClassicSetKey(NFC_KeyStore); // Set Key
              if(result == Result.Success) {
                String NFC_Authentificate_Block;
                NFC_Authentificate_Block = "1";
                result = SendCommand.NFCMifareClassicAuthenticateBlock(NFC_Authentificate_Block); // Authentificate Block
                if(result == Result.Success) {
                  String MifareData, NFC_Read_Block;
                  NFC_Read_Block = "1";
                  MifareData = SendCommand.NFCMifareClassicReadBlock(NFC_Read_Block); // Get NFC Data
                  SendCommand.NFCReadComplete();
              }
          }
          else if(NFCbuff[0] == 0x0f) //jcop
          {
             byte[] JCOP = new byte[NFCbuff.length-1];

             for(int i = 0; i < (NFCbuff.length-1); i++) {
                JCOP[i] = NFCbuff[i+1]; // JCOP UID Data
             }

             byte NFC_APDU[] = {0x00, 0xA4, 0x04, 0x00, 0x07, 0xd4, 0x10, 0x65, 0x09, 0x90, 0x00, 0x20, 0x00};
             String data = SendCommand.NFCTypeADataExchange(NFC_APDU); // Get NFC Data
             SendCommand.NFCReadComplete();
          }
          else if(NFCbuff[0] == 0xc0) //Type B
          {
             byte[] TypeBUID = new byte[NFCbuff.length-1];

             for(int i = 0; i < (NFCbuff.length-1); i++) {
                TypeBUID[i] = NFCbuff[i+1]; // Type B UID Data
             }

             byte NFC_APDU[] = {0x00, 0xA4, 0x04, 0x00, 0x07, 0xd4, 0x10, 0x65, 0x09, 0x90, 0x00, 0x20, 0x00};
             String data = SendCommand.NFCTypeBDataExchange(NFC_APDU); // Get NFC Data
             SendCommand.NFCReadComplete();
          }
          else if((NotiNFCData[0] == 0x01)  //Mifare Ultralight
               || (NotiNFCData[0] == 0x02)  //Mifare UltralightC
               || (NotiNFCData[0] == 0x06)  //Mifare plus
               || (NotiNFCData[0] == 0x07)  //Mifare plus 2k sl1
               || (NotiNFCData[0] == 0x08)  //Mifare plus 4k sl1
               || (NotiNFCData[0] == 0x09)  //Mifare plus 2k sl2
               || (NotiNFCData[0] == 0x0a)  //Mifare plus 4k sl2
               || (NotiNFCData[0] == 0x0b)  //Mifare plus 2k sl3
               || (NotiNFCData[0] == 0x0c)  //Mifare plus 4k sl3
               || (NotiNFCData[0] == 0x0d)  //Mifare DESFire
               || (NotiNFCData[0] == 0x10)  //Mifare Mini
               || (NotiNFCData[0] == 0x11)  //nPA
               || (NotiNFCData[0] == 0xa0)  //ISO15693
               || (NotiNFCData[0] == 0xb0)  //Type A
               || (NotiNFCData[0] == 0xd0)) //Felica
          {
             byte[] UIDData = new byte[NFCbuff.length-1];

             for(int i = 0; i < (NFCbuff.length-1); i++) {
                UIDData[i] = NFCbuff[i+1]; // Type B UID Data
             }
          }
       }
     }
   };

 ...
 }

See Also

None.

Requirements

Import

import com.PointMobile.PMSyncService.Result;
import com.PointMobile.PMSyncService.SendCommand;

Library PM3SDK.jar